about summary refs log tree commit diff
path: root/fs-tracer-ebpf/Cargo.toml
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2024-01-13 21:05:51 +0100
committerBaitinq <manuelpalenzuelamerino@gmail.com>2024-01-13 21:25:48 +0100
commitea9a3f1af5fe7547617821614b8194e4f484a8e1 (patch)
tree5652060b962ba3c839ac1c18e0e000efaf6bd3e2 /fs-tracer-ebpf/Cargo.toml
downloadfs-tracer-ea9a3f1af5fe7547617821614b8194e4f484a8e1.tar.gz
fs-tracer-ea9a3f1af5fe7547617821614b8194e4f484a8e1.tar.bz2
fs-tracer-ea9a3f1af5fe7547617821614b8194e4f484a8e1.zip
Initial commit
Diffstat (limited to 'fs-tracer-ebpf/Cargo.toml')
-rw-r--r--fs-tracer-ebpf/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/fs-tracer-ebpf/Cargo.toml b/fs-tracer-ebpf/Cargo.toml
new file mode 100644
index 0000000..37af91d
--- /dev/null
+++ b/fs-tracer-ebpf/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "fs-tracer-ebpf"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+aya-bpf = { git = "https://github.com/aya-rs/aya" }
+aya-log-ebpf = { git = "https://github.com/aya-rs/aya" }
+fs-tracer-common = { path = "../fs-tracer-common" }
+
+[[bin]]
+name = "fs-tracer"
+path = "src/main.rs"
+
+[profile.dev]
+opt-level = 3
+debug = false
+debug-assertions = false
+overflow-checks = false
+lto = true
+panic = "abort"
+incremental = false
+codegen-units = 1
+rpath = false
+
+[profile.release]
+lto = true
+panic = "abort"
+codegen-units = 1
+
+[workspace]
+members = []