about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-08-17 01:10:37 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-08-17 01:24:48 +0200
commitcd5c9930afd91779d79e86ae1bb2924046dfbdee (patch)
tree1c3ec3dcc29d7b9a292f38c5c54658efd7762fbf /flake.nix
downloadisspass-cd5c9930afd91779d79e86ae1bb2924046dfbdee.tar.gz
isspass-cd5c9930afd91779d79e86ae1bb2924046dfbdee.tar.bz2
isspass-cd5c9930afd91779d79e86ae1bb2924046dfbdee.zip
Setup nix dev environment
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..27b1ea7
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,16 @@
+{
+  description = "isspass flake";
+
+  inputs.flake-utils.url = "github:numtide/flake-utils";
+
+  outputs = { self, nixpkgs, flake-utils }:
+
+    flake-utils.lib.eachDefaultSystem
+      (system:
+        let pkgs = nixpkgs.legacyPackages.${system}; in
+        {
+          devShells.default = import ./shell.nix { inherit pkgs; };
+        }
+      );
+
+}