about summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorCiro Mattia Gonano <ciro@winged.it>2013-03-06 23:16:50 +0100
committerCiro Mattia Gonano <ciro@winged.it>2013-03-06 23:16:50 +0100
commit2dab7a707b00e75c77e794f758ebe7da62be826a (patch)
tree3cb9e35f0c532521de769eb748cd5e99831adef4 /setup.py
parentUse splitlines() instead of regexp (fixes #25) (diff)
downloadkcc-2dab7a707b00e75c77e794f758ebe7da62be826a.tar.gz
kcc-2dab7a707b00e75c77e794f758ebe7da62be826a.tar.bz2
kcc-2dab7a707b00e75c77e794f758ebe7da62be826a.zip
Update setup with Windows icon
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index dcaedf6..cc4781a 100644
--- a/setup.py
+++ b/setup.py
@@ -43,7 +43,13 @@ elif sys.platform == 'win32':
     from cx_Freeze import setup, Executable
     base = "Win32GUI"
     extra_options = dict(
-        executables=[Executable("kcc.py", base=base)]
+        executables=[Executable("kcc.py", base=base, icon='resources/comic2ebook.ico',
+                                appendScriptToExe=True, appendScriptToLibrary=False)],
+        options=dict(
+            build_exe=dict(
+                compressed=True
+            )
+        )
     )
 else:
     extra_options = dict(