about summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorPaweł Jastrzębski <pawelj@iosphe.re>2019-03-06 19:46:06 +0100
committerPaweł Jastrzębski <pawelj@iosphe.re>2019-03-06 19:50:17 +0100
commit409f077c3e88cb7a1cbd84ef252c8d18c8a5e9fb (patch)
treeff7ce476b790fc0e4c790922285ac481e59aafcd /setup.py
parentFixed metadata encoding (close #281) (diff)
downloadkcc-409f077c3e88cb7a1cbd84ef252c8d18c8a5e9fb.tar.gz
kcc-409f077c3e88cb7a1cbd84ef252c8d18c8a5e9fb.tar.bz2
kcc-409f077c3e88cb7a1cbd84ef252c8d18c8a5e9fb.zip
Bye, bye DEBs
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py18
1 files changed, 1 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 182be17..7bc5c8d 100755
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@ pip/pyinstaller build script for KCC.
 Install as Python package:
     python3 setup.py install
 
-Create EXE/APP/DEB:
+Create EXE/APP:
     python3 setup.py build_binary
 """
 
@@ -49,22 +49,6 @@ class BuildBinaryCommand(distutils.cmd.Command):
             os.system('pyinstaller -y -F -i icons\\comic2ebook.ico -n KCC -w --noupx kcc.py')
             exit(0)
         else:
-            os.system('pyinstaller -y -F kcc.py')
-            os.system('mkdir -p dist/usr/bin dist/usr/share/applications dist/usr/share/doc/kindlecomicconverter '
-                      'dist/usr/share/kindlecomicconverter dist/usr/share/lintian/overrides')
-            os.system('mv dist/kcc dist/usr/bin')
-            os.system('cp icons/comic2ebook.png dist/usr/share/kindlecomicconverter')
-            os.system('cp LICENSE.txt dist/usr/share/doc/kindlecomicconverter/copyright')
-            os.system('cp other/linux/kindlecomicconverter.desktop dist/usr/share/applications')
-            os.system('cp other/linux/kindlecomicconverter dist/usr/share/lintian/overrides')
-            os.chdir('dist')
-            os.system('fpm -f -s dir -t deb -n kindlecomicconverter -v ' + VERSION +
-                      ' -m "Pawel Jastrzebski <pawelj@iosphe.re>" --license "ISC" '
-                      '--description "$(printf "Comic and Manga converter for e-book '
-                      'readers.\nThis app allows you to transform your PNG, JPG, GIF, '
-                      'CBZ, CBR and CB7 files\ninto EPUB or MOBI format e-books.")" '
-                      '--url "https://kcc.iosphe.re/" --deb-priority "optional" --vendor "" '
-                      '--category "graphics" -d "p7zip-full" -d "p7zip-rar" -d "libc6" usr')
             exit(0)