about summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorCiro Mattia Gonano <ciromattia@gmail.com>2013-01-28 11:59:43 +0100
committerCiro Mattia Gonano <ciromattia@gmail.com>2013-01-28 11:59:43 +0100
commit74a93f1e507ae4bb2e1620cf5169fad62dbf8086 (patch)
tree9b5e5b84c593d09352e63709f58aff42b8a7648a /setup.py
parentUpdate rarfile.py from https://github.com/markokr/rarfile (diff)
downloadkcc-74a93f1e507ae4bb2e1620cf5169fad62dbf8086.tar.gz
kcc-74a93f1e507ae4bb2e1620cf5169fad62dbf8086.tar.bz2
kcc-74a93f1e507ae4bb2e1620cf5169fad62dbf8086.zip
Added MANIFEST.in, ugly fix for OSX not evaluating user local $PATH on app launched from Finder.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 11 insertions, 18 deletions
diff --git a/setup.py b/setup.py
index 736a3fa..4112376 100644
--- a/setup.py
+++ b/setup.py
@@ -16,30 +16,24 @@ ez_setup.use_setuptools()
 import sys
 from setuptools import setup
 
-NAME="KindleComicConverter"
-VERSION="2.0"
-IDENTIFIER="com.github.ciromattia.kcc"
-EXENAME="KindleComicConverter"
-
-APP = ['kcc.py']
-DATA_FILES = []
-OPTIONS = { 'argv_emulation': True,
-            'iconfile': 'resources/comic2ebook.icns',
-            'includes': 'kcc/*.py'}
+NAME='KindleComicConverter'
+VERSION="2.1"
+mainscript = 'kcc.py'
 
 if sys.platform == 'darwin':
     extra_options = dict(
         setup_requires=['py2app'],
+        app=[mainscript],
         options=dict(
-            py2app=dict(OPTIONS,
-                #resources=['LICENSE.txt','resources/Scripts','resources/description.rtfd'],
-                resources=['LICENSE.txt','resources/description.rtfd'],
+            py2app=dict(
+                argv_emulation=True,
+                iconfile='resources/comic2ebook.icns',
                 plist=dict(
                     CFBundleName               = NAME,
                     CFBundleShortVersionString = VERSION,
                     CFBundleGetInfoString      = NAME + " " + VERSION + ", written 2012-2013 by Ciro Mattia Gonano",
-                    CFBundleExecutable         = EXENAME,
-                    CFBundleIdentifier         = IDENTIFIER,
+                    CFBundleExecutable         = NAME,
+                    CFBundleIdentifier         = 'com.github.ciromattia.kcc',
                     CFBundleSignature       = 'dplt'
                 )
             )
@@ -48,18 +42,17 @@ if sys.platform == 'darwin':
 elif sys.platform == 'win32':
     extra_options = dict(
         setup_requires=['py2exe'],
+        app=[mainscript]
     )
 else:
     extra_options = dict(
         # Normally unix-like platforms will use "setup.py install"
         # and install the main script as such
-        scripts=APP,
+        scripts=[mainscript],
     )
 
 setup(
     name=NAME,
-    app=APP,
-    data_files=DATA_FILES,
     version=VERSION,
     author="Ciro Mattia Gonano",
     author_email="ciromattia@gmail.com",