about summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorPaweł Jastrzębski <pawelj@vulturis.eu>2013-09-19 11:01:15 +0200
committerPaweł Jastrzębski <pawelj@vulturis.eu>2013-09-19 11:01:15 +0200
commitab8effbc3238355278a398a3646850fbcb449bb7 (patch)
tree31971a57248269b8460a4a3fe46adb1279e23df5 /setup.py
parentUpdated README and version bump (diff)
downloadkcc-ab8effbc3238355278a398a3646850fbcb449bb7.tar.gz
kcc-ab8effbc3238355278a398a3646850fbcb449bb7.tar.bz2
kcc-ab8effbc3238355278a398a3646850fbcb449bb7.zip
Added 7z/CB7 support
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9d95d63..35edd24 100644
--- a/setup.py
+++ b/setup.py
@@ -41,7 +41,11 @@ elif platform == "win32":
     from cx_Freeze import setup, Executable
     base = "Win32GUI"
     extra_options = dict(
-        options={"build_exe": {"include_files": ['LICENSE.txt', ['other/UnRAR.exe', 'UnRAR.exe']], "compressed": True}},
+        options={"build_exe": {"include_files": ['LICENSE.txt',
+                                                 ['other/UnRAR.exe', 'UnRAR.exe'],
+                                                 ['other/7za.exe', '7za.exe'],
+                                                 ['other/Additional-LICENSE.txt', 'Additional-LICENSE.txt']
+                                                 ], "compressed": True}},
         executables=[Executable(MAIN,
                                 base=base,
                                 targetName="KCC.exe",