about summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorPaweł Jastrzębski <pawelj@vulturis.eu>2013-10-10 17:07:44 +0200
committerPaweł Jastrzębski <pawelj@vulturis.eu>2013-10-10 17:07:44 +0200
commitcbf87df551ac44569839d766f0fb085999e614ef (patch)
tree7d33527abfa2a31fb73da741028abda598c95555 /setup.py
parentSlugify: Unicode fix (diff)
downloadkcc-cbf87df551ac44569839d766f0fb085999e614ef.tar.gz
kcc-cbf87df551ac44569839d766f0fb085999e614ef.tar.bz2
kcc-cbf87df551ac44569839d766f0fb085999e614ef.zip
OSX: File association
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a72f319..0ff8dd8 100644
--- a/setup.py
+++ b/setup.py
@@ -32,6 +32,13 @@ if platform == "darwin":
                     CFBundleExecutable=NAME,
                     CFBundleIdentifier='com.github.ciromattia.kcc',
                     CFBundleSignature='dplt',
+                    CFBundleDocumentTypes=[
+                        dict(
+                            CFBundleTypeExtensions=['.cbz', '.cbr', '.cb7', '.zip', '.rar', '.7z', '.pdf'],
+                            CFBundleTypeIconFile='comic2ebook.icns',
+                            CFBundleTypeRole='Viewer',
+                        )
+                    ],
                     NSHumanReadableCopyright='ISC License (ISCL)'
                 )
             )