about summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorCiro Mattia Gonano <ciromattia@gmail.com>2012-12-17 10:45:24 +0100
committerCiro Mattia Gonano <ciromattia@gmail.com>2012-12-17 10:45:24 +0100
commitdd90ab590831f3c609957fcf5d55e0fa2fc85205 (patch)
tree9d80890249fc702a538af02f4f58bed8db8b0458 /setup.py
parentAdd basilar script to sync AppleScript droplet. (diff)
downloadkcc-dd90ab590831f3c609957fcf5d55e0fa2fc85205.tar.gz
kcc-dd90ab590831f3c609957fcf5d55e0fa2fc85205.tar.bz2
kcc-dd90ab590831f3c609957fcf5d55e0fa2fc85205.zip
Start to work on py2exe/py2app ready code.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py25
1 files changed, 12 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index f2628e9..f03adf2 100644
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ VERSION="1.2.0"
 IDENTIFIER="com.github.ciromattia.kcc"
 EXENAME="KindleComicConverter"
 
-APP = ['kcc/comic2ebook.py']
+APP = ['kcc.py']
 DATA_FILES = []
 OPTIONS = { 'argv_emulation': True,
             'iconfile': 'resources/comic2ebook.icns',
@@ -36,20 +36,10 @@ if sys.platform == 'darwin':
                 plist=dict(
                     CFBundleName               = NAME,
                     CFBundleShortVersionString = VERSION,
-                    CFBundleGetInfoString      = NAME + " " + VERSION,
+                    CFBundleGetInfoString      = NAME + " " + VERSION + ", written 2012 by Ciro Mattia Gonano",
                     CFBundleExecutable         = EXENAME,
                     CFBundleIdentifier         = IDENTIFIER,
-                    CFBundleDocumentTypes      = dict(
-                        CFBundleTypeExtensions=["zip","rar","cbz","cbr"],
-                        CFBundleTypeName="Comics",
-                        CFBundleTypeRole="Editor",
-                        LSItemContentTypes = [
-                                             "public.plain-text",
-                                             "public.text",
-                                             "public.data",
-                                             "com.apple.application-bundle"
-                        ]
-                    )
+                    CFBundleSignature       = 'dplt'
                 )
             )
         )
@@ -69,5 +59,14 @@ setup(
     name=NAME,
     app=APP,
     data_files=DATA_FILES,
+    classifiers=[
+        # make sure to use :: Python *and* :: Python :: 3 so
+        # that pypi can list the package on the python 3 page
+        'Programming Language :: Python',
+        'Programming Language :: Python :: 3'
+    ],
+    packages=['kcc'],
+    # make sure to add custom_fixers to the MANIFEST.in
+    include_package_data=True,
     **extra_options
 )