about summary refs log tree commit diff
path: root/setup.py
diff options
context:
space:
mode:
authorPaweł Jastrzębski <pawelj@vulturis.eu>2014-01-22 17:43:19 +0100
committerPaweł Jastrzębski <pawelj@vulturis.eu>2014-01-22 17:43:19 +0100
commitebe7d910deb304ec0941d47e3e6f30c52b20a5b1 (patch)
treed37167f755c590f9ce11a6a47b56d8a31b27c635 /setup.py
parentAdded experimental Linux setup (diff)
downloadkcc-ebe7d910deb304ec0941d47e3e6f30c52b20a5b1.tar.gz
kcc-ebe7d910deb304ec0941d47e3e6f30c52b20a5b1.tar.bz2
kcc-ebe7d910deb304ec0941d47e3e6f30c52b20a5b1.zip
Reverting setup changes
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py36
1 files changed, 4 insertions, 32 deletions
diff --git a/setup.py b/setup.py
index 9d73375..6ca1a59 100755
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ cx_Freeze build script for KCC.
 Usage (Mac OS X):
     python setup.py py2app
 
-Usage (Windows/Linux):
+Usage (Windows):
     python setup.py build
 """
 from sys import platform, version_info
@@ -80,23 +80,8 @@ elif platform == "win32":
                                 icon="icons/comic2ebook.ico",
                                 compress=False)])
 else:
-    import platform as arch
-    import os
-    from cx_Freeze import setup, Executable
-    if arch.architecture()[0] == '64bit':
-        library = 'x86_64'
-    else:
-        library = 'x86'
-    extra_options = dict(
-        options={"build_exe": {"optimize": 2,
-                               "copy_dependent_files": True,
-                               "create_shared_zip": False,
-                               "append_script_to_exe": True,
-                               "init_script": os.path.join(os.getcwd(), 'other', 'LinuxInit.py'),
-                               "excludes": ['tkinter']}},
-        executables=[Executable(MAIN,
-                                base=None,
-                                compress=False)])
+    print('Please use setup.sh to build Linux package.')
+    exit()
 
 #noinspection PyUnboundLocalVariable
 setup(
@@ -118,17 +103,4 @@ if platform == "darwin":
     makedirs('dist/' + NAME + '.app/Contents/PlugIns/platforms')
     copyfile('other/libqcocoa.dylib', 'dist/' + NAME + '.app/Contents/PlugIns/platforms/libqcocoa.dylib')
     chmod('dist/' + NAME + '.app/Contents/Resources/unrar', 0o777)
-    chmod('dist/' + NAME + '.app/Contents/Resources/7za', 0o777)
-
-if platform == "linux":
-    from os import chmod, makedirs, remove
-    from shutil import copyfile, copytree
-    makedirs('dist/kcc/bin')
-    # noinspection PyUnboundLocalVariable
-    copyfile('build/exe.linux-' + library + '-3.3/kcc', 'dist/kcc/bin/kcc')
-    chmod('dist/kcc/bin/kcc', 0o755)
-    # noinspection PyUnboundLocalVariable
-    copytree('build/exe.linux-' + library + '-3.3', 'dist/kcc/lib')
-    remove('dist/kcc/lib/kcc')
-    copyfile('LICENSE.txt', 'dist/kcc/LICENSE.txt')
-    copyfile('icons/comic2ebook.png', 'dist/kcc/kcc.png')
\ No newline at end of file
+    chmod('dist/' + NAME + '.app/Contents/Resources/7za', 0o777)
\ No newline at end of file