about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-10-07 01:37:59 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-10-07 11:37:52 +0200
commitbe39a0bd06ba0dabab691ef6da6db4162cce1d0c (patch)
tree2c88a5a1f1d37a87899e04a78118aa13e88bda63 /flake.nix
downloadlinux-development-workflow-be39a0bd06ba0dabab691ef6da6db4162cce1d0c.tar.gz
linux-development-workflow-be39a0bd06ba0dabab691ef6da6db4162cce1d0c.tar.bz2
linux-development-workflow-be39a0bd06ba0dabab691ef6da6db4162cce1d0c.zip
Initial commit HEAD master
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..9331325
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,16 @@
+{
+  description = "My Linux development workflow's flake!";
+
+  inputs.flake-utils.url = "github:numtide/flake-utils";
+
+  outputs = { self, nixpkgs, flake-utils }:
+
+    flake-utils.lib.eachDefaultSystem
+      (system:
+        let pkgs = nixpkgs.legacyPackages.${system}; in
+        {
+          devShells.default = import ./linux.nix { inherit pkgs; };
+        }
+      );
+
+}