about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-09 01:15:18 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-18 15:22:22 +0200
commit6795b5bd64c240cd989b2db12eb5c4652e48aecd (patch)
treeb1fed97244faeab8d58defcc28c9b388db06a50d /flake.nix
parentRiver: Change exit to Mod+Ctrl+Shift E (diff)
downloadnixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.tar.gz
nixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.tar.bz2
nixos-config-6795b5bd64c240cd989b2db12eb5c4652e48aecd.zip
Implement host-hardware separation
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index e5435fd..2becc78 100644
--- a/flake.nix
+++ b/flake.nix
@@ -37,6 +37,7 @@
         isNixOS = true;
         extraModules = [ ];
         isIso = false;
+        isHardware = true;
         inherit (nixpkgs) lib;
         inherit inputs user nixpkgs home-manager;
       };
@@ -45,6 +46,7 @@
         isNixOS = false;
         extraModules = [ ];
         isIso = false;
+        isHardware = false;
         #no COde duplication here: TODO
         inherit (nixpkgs) lib;
         inherit inputs user nixpkgs home-manager;
@@ -54,10 +56,20 @@
         isNixOS = true;
         extraModules = [ ];
         isIso = true;
+        isHardware = false;
         user = "nixos";
         #no COde duplication here: TODO
         inherit (nixpkgs) lib;
         inherit inputs nixpkgs home-manager;
       };
+
+      nixosNoHardwareConfigurations = import ./hosts {
+        isNixOS = true;
+        extraModules = [ ];
+        isIso = false;
+        isHardware = false;
+        inherit (nixpkgs) lib;
+        inherit inputs user nixpkgs home-manager;
+      };
     };
 }