about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2023-06-02 00:41:29 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2023-06-05 12:58:07 +0200
commitd5752079053091e65b99eb52fbb747050bbb08e8 (patch)
tree718009dff814661086f6385fd8df7cda5bf3c4f9 /flake.nix
parentUpdate (diff)
downloadnixos-config-d5752079053091e65b99eb52fbb747050bbb08e8.tar.gz
nixos-config-d5752079053091e65b99eb52fbb747050bbb08e8.tar.bz2
nixos-config-d5752079053091e65b99eb52fbb747050bbb08e8.zip
Flake: Add nixtest
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 6e1cb82..f77b46e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -20,6 +20,8 @@
 
     nur.url = "github:nix-community/NUR";
 
+    nixtest.url = "github:jetpack-io/nixtest";
+
     nix-index.url = "github:Mic92/nix-index-database";
 
     hosts = {
@@ -117,5 +119,8 @@
 
       # This is highly advised, and will prevent many possible mistakes
       checks = builtins.mapAttrs (system: deployLib: deployLib.deployChecks self.deploy) inputs.deploy-rs.lib;
+
+
+      tests = inputs.nixtest.run ./.;
     };
 }