about summary refs log tree commit diff
path: root/hosts/configuration.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-07-13 17:20:56 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-07-13 17:23:51 +0200
commitc4ab92d285082dfb45f14f6542701489362707dd (patch)
tree86bae89eff436973f8206a6fa596036524a4d0d8 /hosts/configuration.nix
parentRemove unnecessary packages that can be replaced with , (diff)
downloadnixos-config-c4ab92d285082dfb45f14f6542701489362707dd.tar.gz
nixos-config-c4ab92d285082dfb45f14f6542701489362707dd.tar.bz2
nixos-config-c4ab92d285082dfb45f14f6542701489362707dd.zip
Add timezone to the mkHost function
Diffstat (limited to 'hosts/configuration.nix')
-rw-r--r--hosts/configuration.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/hosts/configuration.nix b/hosts/configuration.nix
index e834335..9913f35 100644
--- a/hosts/configuration.nix
+++ b/hosts/configuration.nix
@@ -1,4 +1,4 @@
-{ secrets, lib, pkgs, config, hostname, inputs, user, ... }: {
+{ secrets, lib, pkgs, config, hostname, inputs, user, timezone, ... }: {
 
   imports = [
     ../modules/doas
@@ -25,7 +25,7 @@
   };
 
   # Set your time zone.
-  time.timeZone = "Europe/Madrid";
+  time.timeZone = timezone;
 
   networking = {
     hostName = hostname; # Define your hostname.