about summary refs log tree commit diff
path: root/hosts/home-darwin.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2024-02-17 23:06:44 +0100
committerBaitinq <manuelpalenzuelamerino@gmail.com>2024-02-17 23:06:44 +0100
commit91c3d91d25d92ecc281b5a7afd1a50293e04aae6 (patch)
tree774100dfb87355f47d3963a26d70878096feeeca /hosts/home-darwin.nix
parentDotfiles: Emacs: Use straight as package manager (diff)
downloadnixos-config-91c3d91d25d92ecc281b5a7afd1a50293e04aae6.tar.gz
nixos-config-91c3d91d25d92ecc281b5a7afd1a50293e04aae6.tar.bz2
nixos-config-91c3d91d25d92ecc281b5a7afd1a50293e04aae6.zip
Nix: Add home-manager to darwin
Diffstat (limited to 'hosts/home-darwin.nix')
-rw-r--r--hosts/home-darwin.nix56
1 files changed, 56 insertions, 0 deletions
diff --git a/hosts/home-darwin.nix b/hosts/home-darwin.nix
new file mode 100644
index 0000000..4c177c0
--- /dev/null
+++ b/hosts/home-darwin.nix
@@ -0,0 +1,56 @@
+{  pkgs, stateVersion, lib, dotfiles, user, ... }:
+{
+  imports = [
+  ];
+
+  home = {
+    username = "${user}";
+    homeDirectory = "/Users/${user}";
+
+    packages = with pkgs; [
+      git-crypt
+    ];
+  };
+
+  services = {
+  };
+
+  programs = {
+    emacs = {
+      enable = true;
+      extraPackages = epkgs: with epkgs; [
+        use-package
+
+        direnv
+
+        evil
+        evil-collection
+
+        doom-modeline
+        dashboard
+
+        projectile
+        lsp-ui
+
+        manualPackages.custom.lsp-bridge
+        rust-mode
+        rustic
+        company
+        flycheck
+        lsp-haskell
+
+        nix-mode
+        haskell-mode
+        typescript-mode
+        jq-mode
+
+        doom-themes
+
+        dired-sidebar
+      ];
+      extraConfig = builtins.readFile "${dotfiles}/.emacs";
+    };
+  };
+
+  home.stateVersion = stateVersion;
+}