about summary refs log tree commit diff
path: root/hosts/home.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2024-03-02 12:28:01 +0100
committerBaitinq <manuelpalenzuelamerino@gmail.com>2024-03-02 13:05:09 +0100
commit63e7a3139fb5cc8c08a8924863a3c2a71dd36795 (patch)
tree30b9a5d7990ec0ada3aab98dcb41ac7eaff160ef /hosts/home.nix
parentOverlays: Base: Add emacs with runtime deps to overlay (diff)
downloadnixos-config-63e7a3139fb5cc8c08a8924863a3c2a71dd36795.tar.gz
nixos-config-63e7a3139fb5cc8c08a8924863a3c2a71dd36795.tar.bz2
nixos-config-63e7a3139fb5cc8c08a8924863a3c2a71dd36795.zip
Home: Install emacs packages
Diffstat (limited to 'hosts/home.nix')
-rw-r--r--hosts/home.nix32
1 files changed, 16 insertions, 16 deletions
diff --git a/hosts/home.nix b/hosts/home.nix
index e615a96..576cce5 100644
--- a/hosts/home.nix
+++ b/hosts/home.nix
@@ -156,34 +156,34 @@
     emacs = {
       enable = true;
       extraPackages = epkgs: with epkgs; [
-        use-package
-
         direnv
+        which-key
 
         evil
         evil-collection
 
         doom-modeline
+        doom-themes
         dashboard
 
         projectile
-        lsp-ui
-
-        lsp-bridge
-        rust-mode
+        
+        corfu
+        kind-icon
+        eldoc-box 
+        
+        vertico
+        consult
+        orderless
+        marginalia
+        
+        treesit-auto
+
+        go-mode
         rustic
-        company
-        flycheck
-        lsp-haskell
-
-        nix-mode
-        haskell-mode
-        typescript-mode
-        jq-mode
-
-        doom-themes
 
         dired-sidebar
+        minimap
       ];
       extraConfig = builtins.readFile "${dotfiles}/.emacs";
     };