about summary refs log tree commit diff
path: root/packages/kindlegen/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages/kindlegen/default.nix')
-rw-r--r--packages/kindlegen/default.nix88
1 files changed, 48 insertions, 40 deletions
diff --git a/packages/kindlegen/default.nix b/packages/kindlegen/default.nix
index dd86dec..f96d0c8 100644
--- a/packages/kindlegen/default.nix
+++ b/packages/kindlegen/default.nix
@@ -1,42 +1,50 @@
-{ fetchurl, lib, stdenv, unzip }:
-
-let
+{
+  fetchurl,
+  lib,
+  stdenv,
+  unzip,
+}: let
   version = "2.9";
-  fileVersion = builtins.replaceStrings [ "." ] [ "_" ] version;
-
-  sha256 = {
-    x86_64-linux = "sha256-2ZLFM5YcV2Ym38hxU8WMrRDjHDF6edqYohLeM+ASgpk=";
-  }.${stdenv.hostPlatform.system} or (throw "system #{stdenv.hostPlatform.system.} is not supported");
-
-  url = {
-    x86_64-linux = "https://archive.org/download/kindlegen_linux_2_6_i386_v2_9/kindlegen_linux_2.6_i386_v2_9.tar.gz";
-  }.${stdenv.hostPlatform.system} or (throw "system #{stdenv.hostPlatform.system.} is not supported");
-
+  fileVersion = builtins.replaceStrings ["."] ["_"] version;
+
+  sha256 =
+    {
+      x86_64-linux = "sha256-2ZLFM5YcV2Ym38hxU8WMrRDjHDF6edqYohLeM+ASgpk=";
+    }
+    .${stdenv.hostPlatform.system}
+    or (throw "system #{stdenv.hostPlatform.system.} is not supported");
+
+  url =
+    {
+      x86_64-linux = "https://archive.org/download/kindlegen_linux_2_6_i386_v2_9/kindlegen_linux_2.6_i386_v2_9.tar.gz";
+    }
+    .${stdenv.hostPlatform.system}
+    or (throw "system #{stdenv.hostPlatform.system.} is not supported");
 in
-stdenv.mkDerivation {
-  pname = "kindlegen";
-  inherit version;
-
-  src = fetchurl {
-    inherit url;
-    inherit sha256;
-  };
-
-  sourceRoot = ".";
-
-  nativeBuildInputs = lib.optional (lib.hasSuffix ".zip" url) unzip;
-
-  installPhase = ''
-    mkdir -p $out/bin $out/share/kindlegen/doc
-    install -m755 kindlegen $out/bin/kindlegen
-    cp -r *.txt *.html docs/* $out/share/kindlegen/doc
-  '';
-
-  meta = with lib; {
-    description = "Convert documents to .mobi for use with Amazon Kindle";
-    homepage = "https://www.amazon.com/gp/feature.html?docId=1000765211";
-    license = licenses.unfree;
-    maintainers = with maintainers; [ peterhoeg ];
-    platforms = [ "x86_64-linux" "i686-linux" "x86_64-darwin" "i686-darwin" "x86_64-cygwin" "i686-cygwin" ];
-  };
-}
+  stdenv.mkDerivation {
+    pname = "kindlegen";
+    inherit version;
+
+    src = fetchurl {
+      inherit url;
+      inherit sha256;
+    };
+
+    sourceRoot = ".";
+
+    nativeBuildInputs = lib.optional (lib.hasSuffix ".zip" url) unzip;
+
+    installPhase = ''
+      mkdir -p $out/bin $out/share/kindlegen/doc
+      install -m755 kindlegen $out/bin/kindlegen
+      cp -r *.txt *.html docs/* $out/share/kindlegen/doc
+    '';
+
+    meta = with lib; {
+      description = "Convert documents to .mobi for use with Amazon Kindle";
+      homepage = "https://www.amazon.com/gp/feature.html?docId=1000765211";
+      license = licenses.unfree;
+      maintainers = with maintainers; [peterhoeg];
+      platforms = ["x86_64-linux" "i686-linux" "x86_64-darwin" "i686-darwin" "x86_64-cygwin" "i686-cygwin"];
+    };
+  }