about summary refs log tree commit diff
path: root/packages/swhkd/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages/swhkd/default.nix')
-rw-r--r--packages/swhkd/default.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/packages/swhkd/default.nix b/packages/swhkd/default.nix
index 4682a36..3bf5091 100644
--- a/packages/swhkd/default.nix
+++ b/packages/swhkd/default.nix
@@ -1,4 +1,9 @@
-{ rustPlatform, fetchFromGitHub, pkgs, ... }:
+{
+  rustPlatform,
+  fetchFromGitHub,
+  pkgs,
+  ...
+}:
 rustPlatform.buildRustPackage rec {
   name = "swhkd";
 
@@ -6,7 +11,7 @@ rustPlatform.buildRustPackage rec {
     pkgconfig
   ];
 
-  buildInputs = with pkgs; [ systemd ];
+  buildInputs = with pkgs; [systemd];
 
   src = fetchFromGitHub {
     owner = "waycrate";
@@ -17,5 +22,5 @@ rustPlatform.buildRustPackage rec {
 
   cargoHash = "sha256-E5AE18CfeX1HI/FbGDFoUDsPyG/CpJrD+8Ky7c+EQUw=";
 }
-
 # Doesn't yet work because NixOS' kernel isn't compiled with CONFIG_RFKILL_INPUT=y
+