about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-16 23:53:35 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-16 23:53:37 +0200
commit4ffe77e828a9cbe01a48602b53058940b1265dc2 (patch)
tree2f6621d52aac9436bed09c951239534438f30a48 /flake.nix
downloadwl-dpms-4ffe77e828a9cbe01a48602b53058940b1265dc2.tar.gz
wl-dpms-4ffe77e828a9cbe01a48602b53058940b1265dc2.tar.bz2
wl-dpms-4ffe77e828a9cbe01a48602b53058940b1265dc2.zip
Initialise project
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..74fd650
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,16 @@
+{
+  description = "baitinq.github.io flake";
+
+  inputs.flake-utils.url = "github:numtide/flake-utils";
+
+  outputs = { self, nixpkgs, flake-utils }:
+
+    flake-utils.lib.eachDefaultSystem
+      (system:
+        let pkgs = nixpkgs.legacyPackages.${system}; in
+        {
+          devShells.default = import ./shell.nix { inherit pkgs; };
+        }
+      );
+
+}