about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-21 19:15:50 +0200
committerBaitinq <manuelpalenzuelamerino@gmail.com>2022-09-22 00:18:59 +0200
commitdb2b37e31f1122da255f48956824586a8451b509 (patch)
tree005244897f620b969e4656a37e35f6e9dc3301db /flake.nix
parentmkHost: Add extraModules argument (diff)
downloadnixos-config-db2b37e31f1122da255f48956824586a8451b509.tar.gz
nixos-config-db2b37e31f1122da255f48956824586a8451b509.tar.bz2
nixos-config-db2b37e31f1122da255f48956824586a8451b509.zip
Flake: Add systems as 'input' to the nix derivation
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 10 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 97627c2..9d87f10 100644
--- a/flake.nix
+++ b/flake.nix
@@ -32,8 +32,8 @@
       dotfiles = ./dotfiles;
 
       hosts = [
-        { host = "phobos"; system = "x86_64-linux"; extraOverlays = [ ]; extraModules = [ ]; timezone = secrets.main_timezone; location = secrets.main_location; }
-        { host = "luna"; system = "x86_64-linux"; extraOverlays = [ ]; extraModules = [ ]; timezone = secrets.main_timezone; location = secrets.main_location; }
+        { host = "phobos"; extraOverlays = [ ]; extraModules = [ ]; timezone = secrets.main_timezone; location = secrets.main_location; }
+        { host = "luna"; extraOverlays = [ ]; extraModules = [ ]; timezone = secrets.main_timezone; location = secrets.main_location; }
       ];
 
       hardwares = [
@@ -42,11 +42,18 @@
         { hardware = "virtualbox"; }
       ];
 
+      systems = [
+        { system = "x86_64-linux"; }
+        { system = "x86_64-darwin"; }
+        { system = "aarch64-linux"; }
+        { system = "aarch64-darwin"; }
+      ];
+
 
       commonInherits = {
         inherit (nixpkgs) lib;
         inherit inputs nixpkgs home-manager;
-        inherit user secrets dotfiles hosts hardwares;
+        inherit user secrets dotfiles hosts hardwares systems;
       };
     in
     {